Jenkins (and Others) about Dropping Support for Java 5

As an Open Source developer, I'm used to trying to support as many reasonable things for my users as possible. However, this has never included support for Java 5, which itself is hardly supported by popular Java vendors anymore. Hence jOOQ requires Java 6 or more to compile and run. There is now an interesting initiative … Continue reading Jenkins (and Others) about Dropping Support for Java 5

The Great Benevolent Dictator Getting Some Beating

I know how it feels to be a benevolent dictator. I am one myself on my jOOQ User Group. Supporting Free Open Source Software isn't always easy. Sometimes you get demanding users, sometimes you get grumpy bugfixers. And the occasional troll. You try to be nice and sometimes, you make mistakes, too. But hey, even … Continue reading The Great Benevolent Dictator Getting Some Beating